oleksii

Magento 2 Backwards Compatible Policy

Magento 2 Architect Magento Commerce
 

Abstract:

gb
Tech talk

Since publishing Magento 2.0.0 on November 2015, we’ve extended the codebase with sixteen 2.x patch releases and 1 minor release.
We understand that the Magento 2.x upgrade process is challenging and can raise compatibility issues for extension developers. To simplify this upgrade process, the Magento 2 development team has prepared a Backward Compatibility policy, which is specifically focused on minimizing compatibility issues with Magento 2 extensions.
In this presentation, we’ll discuss Magento’s 2.x Backward Compatibility policy. We’ll identify the code that you can rely on during extension development, as well as the parts of Magento 2.x codebase where we might introduce breaking changes in upcoming patch or minor releases.
We will also share our best practices for how to optimally configure dependencies on Magento 2.x packages to improve the compatibility of your extensions.

Watch the speech.

Watch the video interview. (the interview will be uploaded soon)